ChangeRequest #102

forbid passing a registered remote object via Callback to client

Added by achristian about 7 years ago. Updated over 6 years ago.

Status:ClosedStart date:09/16/2011
Priority:NormalDue date:
Assignee:achristian% Done:

100%

Category:CoreEstimated time:1.00 h
Target version:1.1.3

Description

Ensure that a RemoteObject which has been registered via bind(), cannot be passed as a callback to the client.

Otherwise the leacving client will partly clean up the lookup table and will eliminate the method hashs. Any further client will not be able to use any remote method of this remote object.

See: http://dev.root1.de/boards/7/topics/437

Associated revisions

Revision 590
Added by achristian over 6 years ago

fixed issue #102 for 1.1.x branch as well as in trunk for 1.2.0

History

#1 Updated by achristian over 6 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
  • Estimated time set to 1.00

fixed by adding an additional check which in case throws an exception.#

Stacktrace will look like this:

de.root1.simon.exceptions.SimonRemoteException: Errow while invoking 'roi#public abstract de.root1.simon.test.clientcallback.RemoteObject de.root1.simon.test.clientcallback.RemoteObject.getRemoteObject()' due to underlying exception: class de.root1.simon.exceptions.SimonException
at de.root1.simon.ProcessMessageRunnable.processInvoke(ProcessMessageRunnable.java:497)
at de.root1.simon.ProcessMessageRunnable.run(ProcessMessageRunnable.java:91)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:722)
Caused by: de.root1.simon.exceptions.SimonException: Result of method 'public abstract de.root1.simon.test.clientcallback.RemoteObject de.root1.simon.test.clientcallback.RemoteObject.getRemoteObject()' is a registered remote object. Endpoints can not be transferred.
at de.root1.simon.ProcessMessageRunnable.processInvoke(ProcessMessageRunnable.java:469)
... 4 more

#2 Updated by achristian over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF